Project

General

Profile

Bug #255

offloads more than requested

Added by Woozle Hypertwin about 1 year ago. Updated about 1 year ago.

Status:
Closed
Priority:
Normal
Start date:
09/17/2021
Due date:
% Done:

0%


Description

I moved a couple of tab sets to the end of the list, then I selected from the top of the list to the last item before the tab sets, and offloaded those (save & remove).

(It took several minutes to do this, but I think that's a Firefox issue; it was already being very slow, which is part of why I was offloading.)

What it actually removed was the last 3 of my 6 pinned tabs and one of the two tab sets I had moved, along with the stuff I actually wanted it to remove.

I was able to restore all the tabs, so this isn't a critical bug. (The "worst" of it was having to re-pin the three pinned tabs it removed, which isn't exactly terrible; they were all right at the top.)

On trying again -- saving smaller subsets at first and then finally the rest of the tab -- there was no problem. This time, however, I was saving from the end of the tabs rather than the middle -- so that may be a clue about what triggers the problem.

History

#1 Updated by Woozle Hypertwin about 1 year ago

  • Description updated (diff)

#2 Updated by Woozle Hypertwin about 1 year ago

  • Status changed from New to Feedback
  • Assignee changed from Sophia Dellenbaugh to Woozle Hypertwin

I need to test this to see if I can reliably create failure. When I tested it again, with smaller selections, it worked fine -- possibly because the tabs were all "flattened" by the saving process, so maybe the problem is the TreeTabs structure? Anyway... ball is in my court.

#3 Updated by Woozle Hypertwin about 1 year ago

  • Status changed from Feedback to Closed

Also available in: Atom PDF